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General websites 
 
Before listing individual tools and resources, below is a list of several general websites that provide lots of information 
about Google-related accessibility, accommodation, tools, and resources. 
 

● Google Accessibility site - Google’s official site with information on all the accessibility features built into all of 
their products - http://www.google.com/accessibility/ 

 
● Chrome AT Community - Google+ Community focused on sharing useful Google web apps, extensions, and 

other resources for assistive technology 
https://plus.google.com/u/0/communities/104237884077096555634 
 

● Chrome AT Toolbox (Note: last update was 3/6/15; some suggestions may no longer exist) 
https://sites.google.com/site/gchromeat/home/v2  
 

● OTs with Apps https://otswithapps.com/category/google-chrome/  

 

 
 

 

 
  

 

https://drive.google.com/open?id=13A1prEl36mI7d2_tKdz6Z6uaJvRL_RYfKuSmPkO7FNk
http://www.google.com/accessibility/
https://plus.google.com/u/0/communities/104237884077096555634
https://sites.google.com/site/gchromeat/home/v2
https://otswithapps.com/category/google-chrome/


 Chrome/Chromebook features 
 
The Chromebooks have many accessibility features built in by default, for example: 
 
Accessibility: Go to Settings and search Accessibility > Manage accessibility features. Enable many options including 
ChromeVox (spoken feedback), high contrast mode, or highlight the mouse cursor.  
 
Zoom - User can adjust the zoom level of the browser by pressing: 

● Ctrl and + to zoom in (or pinch out on touchscreen Chromebooks) 
● Ctrl and - to zoom out (or pinch in on touchscreen Chromebooks) 
● Ctrl and 0 (zero) to return to the original zoom level 

 
Font face and size - Users can set the default font face and default font size for all websites. Go to Settings and search 

 Customize fonts. Select the appropriate font size and type. 
  

Keyboard shortcuts - Many common tasks in Chrome can be accomplished with the keyboard. Some common keyboard 
shortcuts are listed below. 
 

● Ctrl+1 through Ctrl+8 = switches to the tab at the specified position number on the tab strip. 
● Ctrl+9 = switches to the last tab. 
● Ctrl+Shift+Tab or Ctrl+PgUp = switches to the previous tab. 
● Ctrl+Tab or Ctrl+PgDown = switches to the next tab. 
● Ctrl+W or Ctrl+F4 = closes the current tab. 

 
A full list of Chrome keyboard shortcuts can be found at: 
https://support.google.com/chromebook/answer/183101?hl=en  
 
To access the built-in accessibility features, click the profile picture at the bottom right of the screen, then the gear to 
open the Settings menu. Search accessibility. 
 

 
 
 
 
Click here for Google’s Accessbility Support page. 

 

https://support.google.com/chromebook/answer/183101?hl=en
https://support.google.com/chromebook/?visit_id=636727903118971048-945985318&rd=2#topic=9016892


 

 
 

Chrome Web Apps and Extensions 
 
In addition to the features Google has built into their products, many developers have created Chrome web apps and 
Chrome extensions that bring extra functionality to Chrome for accessibility and accommodations. 
 
To learn how to install and manage Chrome web apps, see this video: 

● http://www.youtube.com/watch?v=Rw06Pdyt3sU 
 
To learn how to install and manage Chrome extensions, see this video: 

● http://www.youtube.com/watch?v=xQ_eerdCYh4 
 
Below is a list of many useful Chrome web apps and extensions for special needs grouped by topic. Some tools fit into 
more than one topic, but each is only listed once. 
 

 
  

 

http://www.youtube.com/watch?v=Rw06Pdyt3sU
http://www.youtube.com/watch?v=xQ_eerdCYh4


 

 

 

Text to speech 
 

● Read&Write for Google - link 
Provides a drop down menu bar in Google Docs with features including text to speech, translation, and 
highlighting. A paid version is also available that adds a picture dictionary, word prediction, vocabulary list 
builder, and more. 
Note: There is a paid version with all the tools and a free version with a subset of the tools. Educators can get 
the paid version for a year at no cost by filling out the form at: 
http://rw.texthelp.com/drive/home/RegisterTeacher 

 
● Speak It - link 

Text to speech tool that reads any selected text on web pages or PDF’s that are opened in Chrome. Options that 
can be adjusted include speaking rate and choice of voice. 

 
● Chrome Speak - link 

Highlight selection to be read, then right-click and click Read the selected text.  
 

● Click2Speech - link 
Hover over text and it automatically highlights in the entire paragraph in green. Click anywhere on the paragraph 
to start the read-aloud. Right-click the extension, then click Options to see settings. Does not track words as it 
reads. 

 
 

Speech to text 
 

● Fluency Tutor - link 
Students can install the extension so they can choose which content they want to read and read independently 
of the teacher. 
 

● Google Voice Search Hotword - link 
Say “OK Google” on Google’s search page to speak your question, which Google will then search and answer 
aloud. 

 
● Voice Recognition - link 

Voice recognition app that allows the user to dictate the text of a document, then save the text to Google Drive 
or send as an email. 

 
● SpeechPad - link 

Voice recognition app that allows the user to dictate the text of a document, then copy and paste the text to 
another application as needed 

 
● VoiceNote - link 

Voice recognition app that allows the user to dictate the text of a document, then copy and paste the text to 
another application as needed 

 
 

Readability  
 

● Mercury Reader - link 
The Mercury Reader extension for Chrome removes ads and distractions, leaving only text and images for a 
clean and consistent reading view on every site. 

 

https://chrome.google.com/webstore/detail/readwrite-for-google/inoeonmfapjbbkmdafoankkfajkcphgd
http://rw.texthelp.com/drive/home/RegisterTeacher
https://chrome.google.com/webstore/detail/chrome-speak/diagnfimeecdcecjpnkjgbnlelkclcpj
https://chrome.google.com/webstore/detail/click2speech/djfpbemmcokhlllnafdmomgecdlicfhj/related?hl=en
https://chrome.google.com/webstore/detail/share-with-fluency-tutor/nhkfdlkhjojdoggilphgbncejkmdobfp
https://chrome.google.com/webstore/detail/google-voice-search-hotwo/bepbmhgboaologfdajaanbcjmnhjmhfn
https://chrome.google.com/webstore/detail/voice-recognition/ikjmfindklfaonkodbnidahohdfbdhkn
https://chrome.google.com/webstore/detail/speechpad-new-voice-noteb/pjineiicgkijhommbbkldannmfmglbmf
https://chrome.google.com/webstore/detail/voicenote-speech-to-text/hfknjgplnkgjihghcidajejfmldhibfm
https://chrome.google.com/webstore/detail/mercury-reader/oknpjjbmpnndlpmnhmekjpocelpnlfdi?hl=en


 

 

 
● OpenDyslexic - link 

This extension overrides all fonts on webpages with the OpenDyslexic font, and formats pages to be more easily 
readable.  

 
● BeeLine Reader - link 

Creates a more readable version of a web page by removing all the ads, comments, and other extra distracting 
items. Then applies a color gradient to the page text guide your eye from one line to the next. 

 
● Change Colors - link 

Quickly change the background color, text colors, font face, and font size for a specific webpage or all webpages. 
 

● ATbar - link 
Change the colors and font size for a webpage, have text read aloud, use colored overlays, remove distracting 
elements from the page, and more 

 
● MagicScroll Web Reader - link 

Turn web pages into a flippable e-book with easy clickable or keyboard control, as well as control over font size 
and page color as well. 
 

● Prizmo Go (iPad app) - link 
Take a picture of any book page. Prizmo will convert the text to OCR. Click the megaphone icon to read the text 
aloud. 
 

● Screen Shade by EdTechTeam - link 
ScreenShade by EdTechTeam lets you quickly and easily cover your screen, or a portion of it. You can use 
ScreenShade to hide the answers to questions, block out something you don't want an audience to see, or let 
students uncover if they know the answer.  

 

Reading comprehension 
 

● TLDR (Too Long, Didn’t Read) - link 
Creates a short summary of any web page article. 

 
● Clipped - link 

Creates a bulleted list of the main points of an article or website. 
 

● CruxLight - link 
Creates a shortened summarized version of a web page article and a list of important keywords from the text. 
The user can adjust the length of the summary as desired. 

 
● Google Dictionary - link 

Double-click any word on a web page to get a pop-up with the definition and audible pronunciation. 
 

● Newsela - link 
Current event articles covering many subjects, each written at five different Lexile levels so all students can read 
the same material at an appropriate level. 

 

Math 
● Calculator - link 

Calculator with functions for basic arithmetic, algebra, trigonometry, and more. 

 

https://chrome.google.com/webstore/detail/opendyslexic/cdnapgfjopgaggbmfgbiinmmbdcglnam
https://chrome.google.com/webstore/detail/beeline-reader/ifjafammaookpiajfbedmacfldaiamgg
https://chrome.google.com/webstore/detail/change-colors/jbmkekhehjedonbhoikhhkmlapalklgn
https://chrome.google.com/webstore/detail/atbar/lihjlachbdicbhpalgegcgknkbmjhicl
https://chrome.google.com/webstore/detail/magicscroll-web-reader/ecldhagehndokdmaiaigoaecbmbnmfkc
https://itunes.apple.com/us/app/prizmo-go-instant-text-ocr/id1183367390?mt=8
https://chrome.google.com/webstore/detail/screenshade-by-edtechteam/blldpkanceikpdmelclpeodlmhohhobo
https://chrome.google.com/webstore/detail/tldr/giepilabiomhlcmlefmbfkgeoccfhhhc
https://chrome.google.com/webstore/detail/clipped/khpdkdolpjadkjmkamooilpiihccmhnb
https://chrome.google.com/webstore/detail/cruxlight/dnjjifififbedmgbnnpdkcfjfpnhnpce
https://chrome.google.com/webstore/detail/google-dictionary-by-goog/mgijmajocgfcbeboacabfgobmjgjcoja
https://chrome.google.com/webstore/detail/newsela/bfpeiapdhnegnfcfkdfihabadngjagfj
https://chrome.google.com/webstore/detail/calculator/joodangkbfjnajiiifokapkpmhfnpleo


 

 

 

 

 
● Equatio - link 

Type or handwrite any mathematical expression directly on your keyboard or touchscreen. 
 

● Geoboard - link 
Virtual pegboard with virtual rubber bands. 
 

● Geogebra - link 
Graphing, geometry and more, all in one location. 
 

● Desmos Graphing Calculator - link 
Plot functions, create tables, animate your graphs, and more. 
 

 
Navigation 
 

● Click-free Browsing - link 
Adds navigation icons to a webpage that can be activated by simply hovering over them, rather than needing to 
click. Commands include scrolling, backward and forward in page history, opening a link, and more. 

 
● Vimium - link - YouTube video 

Provides keyboard shortcuts for navigation and control for someone with difficulty using a mouse. 
 

● CrxMouse - link 
Use mouse gestures to navigate including forward, backward, scrolling, refreshing, switching tabs, and more. 
The user can even program their own custom mouse gestures to open programs and perform other tasks. 

 
 

Classroom management 
 

● PBIS World - link 
 

● ClassDojo - Chrome extension | Website 
Behavior management tool to build positive learning habits and behaviors. 

 
● Class Charts - link 

Seating chart tool with behavior and data tracking. 
 

Communication 
 

● Picto4Me - link 
Allows you to create, edit, download, and play pictographic communication boards 

 

More apps and extensions 
 
For more educational apps and extensions (not necessarily specifically for special needs) see the following resources: 
 

● Web App Reviews: http://www.webappreviews.org/ 
 

● Chrome web apps: http://google.apps.sparcc.org/resources/web-apps 

 

https://chrome.google.com/webstore/detail/equatio-math-made-digital/hjngolefdpdnooamgdldlkjgmdcmcjnc
https://chrome.google.com/webstore/detail/geoboard-by-the-math-lear/gaakmmdiopnmcenkojohldanladpajak
https://chrome.google.com/webstore/detail/geogebra-classic/bnbaboaihhkjoaolfnfoablhllahjnee
https://chrome.google.com/webstore/detail/desmos-graphing-calculato/bhdheahnajobgndecdbggfmcojekgdko
https://chrome.google.com/webstore/detail/click-free-browsing/ipfpfhnlkoddglhimhdbboidjcfjlkji
https://chrome.google.com/webstore/detail/vimium/dbepggeogbaibhgnhhndojpepiihcmeb
https://www.youtube.com/watch?v=t67Sn0RGK54
https://chrome.google.com/webstore/detail/crxmouse/jlgkpaicikihijadgifklkbpdajbkhjo
http://www.pbisworld.com/
https://chrome.google.com/webstore/detail/classdojo-extension/mbhcppckcncdempkomncfipbddlkofio?hl=en
https://www.classdojo.com/
https://chrome.google.com/webstore/detail/class-charts/pjmmpemannlahkbibemdmhglliakbkbl
https://chrome.google.com/webstore/detail/picto4me-aac-communicatio/hdckhnghilfajdimkkfhfejcihcdlgdl
http://www.webappreviews.org/
http://google.apps.sparcc.org/resources/web-apps


 

 

 
● Chrome extensions: http://google.apps.sparcc.org/resources/extensions 

 
 

 
 

Google Docs: Hidden features you may not have noticed on the menu 
 
File > Version history. Allows user to see previous versions of the doc and revert to any previous version 
 
File > Page Setup. Use Page Color options to change background color if needed to reduce visual stress. 
 
View > Show equation toolbar 
 
Insert > Special characters. From the Symbols 
drop-down menu, select Emoji. On the next 
drop-down, you can select the category of Emoji: 
Once inserted, you can select the Emoji and use the 
Font Size option to enlarge it. 
 
Format > Columns. Fairly recent addition to Google Docs’ capabilities. 
 
Tools > Spelling will spell check the entire document 
 
Tools > Voice Typing. Very accurate speech-to-text utility. Also works in the notes section of Google Slides. 
 
Tools > Translate document. Generates a machine-translated document in the language of your choice. 
 
 

Add-ons are third-party tools that can be installed to extend the features of Google Docs, Sheets, Slides, and Forms. 
Add-ons provide a wide range of new functions including tools for special needs. 
 
To install an add-on, you will use the Add-ons menu on each of the G-Suite tools. Docs add-ons only work in Docs; Sheets 
add-ons only work in Sheets, etc.  
 
Suggested Docs Add-ons: 
 

● Language Tool - link 
Proofread your document and accept or reject suggested changes. 

● Reader - link 
Read the document aloud. 

● Text Help Study Skills - link 
Use 4 colors of highlighters free for 30 days; yellow only after the trial period is over.  

● Word Cloud Generator - link 
Easily view the most frequently used words in any Doc. 

 
 
Thinking in Common: Training Resources 

 
 

  

 

http://google.apps.sparcc.org/resources/extensions
https://docs.google.com/document/d/1amm93uCfe1iePsH_M_oSURRCWI77Jveza008ef6X4EA/edit?addon_store
https://chrome.google.com/webstore/detail/reader/kbklbokcoegaabagnamndbhjmnikjdnp?utm_source=permalink
https://chrome.google.com/webstore/detail/texthelp-study-skills/fjgimeiehjeaammngbkmpmjikfpknmpf?utm_source=permalink
https://chrome.google.com/webstore/detail/word-cloud-generator/demclmhdcbofendohdngkfokmbcgickb
http://thinkingincommon.com/training-resources/


 Other tools for PISD 
 
We now have district licenses for Nearpod and Formative. Sign in with your Google account.  
 
For more information you can read about ways to use Nearpod at this link: 
https://nearpod.com/blog/10-ways-to-use-nearpod-in-the-classroom/ and about ways to use Formative at this one: 
http://community.goformative.com/  
Contact any member of the Instructional Technology team if you need help getting started with either of these two 
useful tools. 

 

https://nearpod.com/
https://goformative.com/
https://nearpod.com/blog/10-ways-to-use-nearpod-in-the-classroom/
http://community.goformative.com/
https://sites.google.com/pisd.edu/pisdrollout/troubleshooting/contact-us?authuser=0

